What’s Vulnerable › Vulnerabilities
CVE-2016-6187
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-08-06 · updated 2026-06-17
- Weakness: CWE-119
Description
The apparmor_setprocattr function in security/apparmor/lsm.c in the Linux kernel before 4.6.5 does not validate the buffer size, which allows local users to gain privileges by triggering an AppArmor setprocattr hook.
Affected products
- Linux kernel: from 4.5 before 4.6.5 — fixed in 4.6.5
How to fix
Upgrade to a fixed version: Linux kernel 4.6.5. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=30a46a4647fd1df9cf52e43bf467f0d9265096ca
- http://marc.info/?l=linux-kernel&m=146793642811929&w=2
- http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.6.5
- http://www.openwall.com/lists/oss-security/2016/07/09/2
- http://www.securityfocus.com/bid/91696
- https://bugzilla.redhat.com/show_bug.cgi?id=1354383
- https://github.com/torvalds/linux/commit/30a46a4647fd1df9cf52e43bf467f0d9265096ca
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=30a46a4647fd1df9cf52e43bf467f0d9265096ca
- http://marc.info/?l=linux-kernel&m=146793642811929&w=2
- http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.6.5
- http://www.openwall.com/lists/oss-security/2016/07/09/2
- http://www.securityfocus.com/bid/91696
Get alerted when CVE-2016-6187 or the next vulnerability affects your stack