What’s Vulnerable › Vulnerabilities
CVE-2016-6207
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-08-12 · updated 2026-06-17
- Weakness: CWE-119
Description
Integer overflow in the _gdContributionsAlloc function in gd_interpolation.c in GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds memory write or memory consumption) via unspecified vectors.
Affected products
- Debian Linux: 8.0
- Libgd: through 2.2.2
- openSUSE Leap: 42.1
- PHP: from 5.5.0 before 5.5.38; from 5.6.0 before 5.6.24; from 7.0.0 before 7.0.9 — fixed in 5.5.38, 5.6.24, 7.0.9
How to fix
Upgrade to a fixed version: PHP 5.5.38, 5.6.24, 7.0.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00086.html
- http://lists.opensuse.org/opensuse-updates/2016-09/msg00078.html
- http://packetstormsecurity.com/files/138174/LibGD-2.2.2-Integer-Overflow-Denial-Of-Service.html
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- http://www.debian.org/security/2016/dsa-3630
- http://www.securityfocus.com/archive/1/539100/100/0/threaded
- http://www.securityfocus.com/bid/92080
- http://www.securitytracker.com/id/1036535
- http://www.ubuntu.com/usn/USN-3060-1
- https://bugs.php.net/bug.php?id=72558
- https://libgd.github.io/release-2.2.3.html
- https://secunia.com/secunia_research/2016-9/
Get alerted when CVE-2016-6207 or the next vulnerability affects your stack