What’s Vulnerable › Vulnerabilities
CVE-2016-6254
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-08-19 · updated 2026-06-17
- Weakness: CWE-119
Description
Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.
Affected products
- Collectd: from 5.4.0 before 5.4.3; from 5.5.0 before 5.5.2 — fixed in 5.4.3, 5.5.2
- Debian Linux: 8.0
- Fedoraproject Fedora: 23, 24
How to fix
Upgrade to a fixed version: Collectd 5.4.3, 5.5.2. Check the vendor advisory for mitigations.
References
- http://collectd.org/news.shtml
- http://www.debian.org/security/2016/dsa-3636
- https://github.com/collectd/collectd/commit/b589096f907052b3a4da2b9ccc9b0e2e888dfc18
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CM4W5SJ4OTBGINGIN4NJLXCUZAZANO6J/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UIZ5UXDOB7BA5NGE2F2I2BL4K6763DHW/
- http://collectd.org/news.shtml
- http://www.debian.org/security/2016/dsa-3636
- https://github.com/collectd/collectd/commit/b589096f907052b3a4da2b9ccc9b0e2e888dfc18
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CM4W5SJ4OTBGINGIN4NJLXCUZAZANO6J/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UIZ5UXDOB7BA5NGE2F2I2BL4K6763DHW/
Get alerted when CVE-2016-6254 or the next vulnerability affects your stack