What’s Vulnerable › Vulnerabilities
CVE-2016-6318
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-09-07 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack-based buffer overflow in the FascistGecosUser function in lib/fascist.c in cracklib allows local users to cause a denial of service (application crash) or gain privileges via a long GECOS field, involving longbuffer.
Affected products
- Cracklib Project Cracklib: from 2.9.0 before 2.9.6 — fixed in 2.9.6
- Debian Linux: 8.0
- openSUSE Leap: 42.1
How to fix
Upgrade to a fixed version: Cracklib Project Cracklib 2.9.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00122.html
- http://www.openwall.com/lists/oss-security/2016/08/16/2
- http://www.securityfocus.com/bid/92478
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/05/msg00023.html
- https://security.gentoo.org/glsa/201612-25
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00122.html
- http://www.openwall.com/lists/oss-security/2016/08/16/2
- http://www.securityfocus.com/bid/92478
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
Get alerted when CVE-2016-6318 or the next vulnerability affects your stack