What’s Vulnerable › Vulnerabilities

CVE-2016-6366: Cisco Adaptive Security Appliance (ASA) SNMP Buffer Overflow Vulnerability

Description

Buffer overflow in Cisco Adaptive Security Appliance (ASA) Software through 9.4.2.3 on ASA 5500, ASA 5500-X, ASA Services Module, ASA 1000V, ASAv, Firepower 9300 ASA Security Module, PIX, and FWSM devices allows remote authenticated users to execute arbitrary code via crafted IPv4 SNMP packets, aka Bug ID CSCva92151 or EXTRABACON.

Affected products

How to fix

Upgrade to a fixed version: Cisco ASA Software 9.0.4.40, 9.1.7\(9\), 9.2.4\(14\), 9.3.3\(10\). Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-6366 or the next vulnerability affects your stack