What’s Vulnerable › Vulnerabilities
CVE-2016-6489
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-14 · updated 2026-06-17
- Weakness: CWE-203
Description
The RSA and DSA decryption code in Nettle makes it easier for attackers to discover private keys via a cache side channel attack.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 16.10
- [UNKNOWN] nettle: before 3.3 — fixed in 3.3
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Hpc Node: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: [UNKNOWN] nettle 3.3. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2582.html
- http://www.openwall.com/lists/oss-security/2016/07/29/7
- http://www.ubuntu.com/usn/USN-3193-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1362016
- https://eprint.iacr.org/2016/596.pdf
- https://git.lysator.liu.se/nettle/nettle/commit/3fe1d6549765ecfb24f0b80b2ed086fdc818bff3
- https://security.gentoo.org/glsa/201706-21
- https://www.oracle.com/security-alerts/cpuapr2020.html
- http://rhn.redhat.com/errata/RHSA-2016-2582.html
- http://www.openwall.com/lists/oss-security/2016/07/29/7
- http://www.ubuntu.com/usn/USN-3193-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1362016
Get alerted when CVE-2016-6489 or the next vulnerability affects your stack