What’s Vulnerable › Vulnerabilities

CVE-2016-6664

Description

mysqld_safe in Oracle MySQL through 5.5.51, 5.6.x through 5.6.32, and 5.7.x through 5.7.14; MariaDB; Percona Server before 5.5.51-38.2, 5.6.x before 5.6.32-78-1, and 5.7.x before 5.7.14-8; and Percona XtraDB Cluster before 5.5.41-37.0, 5.6.x before 5.6.32-25.17, and 5.7.x before 5.7.14-26.17, when using file-based logging, allows local users with access to the mysql account to gain root privileges via a symlink attack on error logs and possibly other files.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.0.29, 10.1.21, 5.5.54; Percona Server 5.5.51-38.2, 5.6.32-78.1, 5.7.14-8; percona Xtradb Cluster 5.5.41-37.0, 5.6.32-25.17, 5.7.14-26.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-6664 or the next vulnerability affects your stack