What’s Vulnerable › Vulnerabilities
CVE-2016-6717
- Severity: high (CVSS 7.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-11-25 · updated 2026-06-17
- Weakness: CWE-264
Description
An elevation of privilege vulnerability in Mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, 6.x before 2016-11-01, and 7.0 before 2016-11-01 could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as Moderate because it first requires exploitation of a separate vulnerability. Android ID: A-31350239.
Affected products
- Android: from 4.0 before 4.4.4; from 5.0 before 5.0.2; from 5.1 before 5.1.1; from 6.0 through 6.0.1; 7.0 — fixed in 4.4.4, 5.0.2, 5.1.1
How to fix
Upgrade to a fixed version: Android 4.4.4, 5.0.2, 5.1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94178
- https://source.android.com/security/bulletin/2016-11-01.html
- http://www.securityfocus.com/bid/94178
- https://source.android.com/security/bulletin/2016-11-01.html
Get alerted when CVE-2016-6717 or the next vulnerability affects your stack