What’s Vulnerable › Vulnerabilities
CVE-2016-6720
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-13 · updated 2026-06-17
- Weakness: CWE-200
Description
An information disclosure vulnerability in libstagefright in Mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, 6.x before 2016-11-01, and 7.0 before 2016-11-01 could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission. Android ID: A-29422020.
Affected products
- Android: from 4.0 before 4.4.4; from 5.0 before 5.0.2; from 5.1 before 5.1.1; from 6.0 through 6.0.1; 7.0 — fixed in 4.4.4, 5.0.2, 5.1.1
How to fix
Upgrade to a fixed version: Android 4.4.4, 5.0.2, 5.1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94143
- https://android.googlesource.com/platform/frameworks/av/+/0f177948ae2640bfe4d70f8e4248e106406b3b0a
- https://android.googlesource.com/platform/frameworks/av/+/2c75e1c3b98e4e94f50c63e2b7694be5f948477c
- https://android.googlesource.com/platform/frameworks/av/+/640b04121d7cd2cac90e2f7c82b97fce05f074a5
- https://android.googlesource.com/platform/frameworks/av/+/7c88b498fda1c2b608a9dd73960a2fd4d7b7e3f7
- https://source.android.com/security/bulletin/2016-11-01.html
- http://www.securityfocus.com/bid/94143
- https://android.googlesource.com/platform/frameworks/av/+/0f177948ae2640bfe4d70f8e4248e106406b3b0a
- https://android.googlesource.com/platform/frameworks/av/+/2c75e1c3b98e4e94f50c63e2b7694be5f948477c
- https://android.googlesource.com/platform/frameworks/av/+/640b04121d7cd2cac90e2f7c82b97fce05f074a5
- https://android.googlesource.com/platform/frameworks/av/+/7c88b498fda1c2b608a9dd73960a2fd4d7b7e3f7
- https://source.android.com/security/bulletin/2016-11-01.html
Get alerted when CVE-2016-6720 or the next vulnerability affects your stack