What’s Vulnerable › Vulnerabilities
CVE-2016-6810
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.
Affected products
- Apache ActiveMQ: from 5.0.0 before 5.14.2 — fixed in 5.14.2
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.14.2. Check the vendor advisory for mitigations.
References
- http://activemq.apache.org/security-advisories.data/CVE-2016-6810-announcement.txt
- http://www.securityfocus.com/bid/94882
- http://www.securitytracker.com/id/1037475
- https://lists.apache.org/thread.html/924a3a27fad192d711436421e02977ff90d9fc0f298e1efe6757cfbc%40%3Cusers.activemq.apache.org%3E
- https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2%40%3Ccommits.activemq.apache.org%3E
- http://activemq.apache.org/security-advisories.data/CVE-2016-6810-announcement.txt
- http://www.securityfocus.com/bid/94882
- http://www.securitytracker.com/id/1037475
- https://lists.apache.org/thread.html/924a3a27fad192d711436421e02977ff90d9fc0f298e1efe6757cfbc%40%3Cusers.activemq.apache.org%3E
- https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2%40%3Ccommits.activemq.apache.org%3E
Get alerted when CVE-2016-6810 or the next vulnerability affects your stack