What’s Vulnerable › Vulnerabilities
CVE-2016-6823
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-18 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the BMP coder in ImageMagick before 7.0.2-10 allows remote attackers to cause a denial of service (crash) via crafted height and width values, which triggers an out-of-bounds write.
Affected products
- ImageMagick: before 6.9.10-50; from 7.0.0-0 before 7.0.2-10 — fixed in 6.9.10-50, 7.0.2-10
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-50, 7.0.2-10. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/26/3
- http://www.securityfocus.com/bid/93158
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=834504
- https://github.com/ImageMagick/ImageMagick/commit/4cc6ec8a4197d4c008577127736bf7985d632323
- http://www.openwall.com/lists/oss-security/2016/09/26/3
- http://www.securityfocus.com/bid/93158
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=834504
- https://github.com/ImageMagick/ImageMagick/commit/4cc6ec8a4197d4c008577127736bf7985d632323
Get alerted when CVE-2016-6823 or the next vulnerability affects your stack