What’s Vulnerable › Vulnerabilities
CVE-2016-6830
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-10 · updated 2026-06-17
- Weakness: CWE-119
Description
The "process-execute" and "process-spawn" procedures in CHICKEN Scheme used fixed-size buffers for holding the arguments and environment variables to use in its execve() call. This would allow user-supplied argument/environment variable lists to trigger a buffer overrun. This affects all releases of CHICKEN up to and including 4.11 (it will be fixed in 4.12 and 5.0, which are not yet released).
Affected products
- chicken: through 4.11.0
References
- http://lists.nongnu.org/archive/html/chicken-announce/2016-08/msg00001.html
- http://www.securityfocus.com/bid/92550
- http://lists.nongnu.org/archive/html/chicken-announce/2016-08/msg00001.html
- http://www.securityfocus.com/bid/92550
Get alerted when CVE-2016-6830 or the next vulnerability affects your stack