What’s Vulnerable › Vulnerabilities
CVE-2016-6835
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-10 · updated 2026-06-17
Description
The vmxnet_tx_pkt_parse_headers function in hw/net/vmxnet_tx_pkt.c in QEMU (aka Quick Emulator) allows local guest OS administrators to cause a denial of service (buffer over-read) by leveraging failure to check IP header length.
Affected products
- Debian Linux: 8.0
- QEMU: before 2.6.0 — fixed in 2.6.0
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: QEMU 2.6.0. Check the vendor advisory for mitigations.
References
- http://git.qemu.org/?p=qemu.git%3Ba=commit%3Bh=93060258ae748573ca7197204125a2670047896d
- http://www.openwall.com/lists/oss-security/2016/08/11/7
- http://www.openwall.com/lists/oss-security/2016/08/18/4
- https://access.redhat.com/errata/RHSA-2017:2392
- https://lists.debian.org/debian-lts-announce/2018/09/msg00007.html
- https://lists.gnu.org/archive/html/qemu-stable/2016-08/msg00077.html
- http://git.qemu.org/?p=qemu.git%3Ba=commit%3Bh=93060258ae748573ca7197204125a2670047896d
- http://www.openwall.com/lists/oss-security/2016/08/11/7
- http://www.openwall.com/lists/oss-security/2016/08/18/4
- https://access.redhat.com/errata/RHSA-2017:2392
- https://lists.debian.org/debian-lts-announce/2018/09/msg00007.html
- https://lists.gnu.org/archive/html/qemu-stable/2016-08/msg00077.html
Get alerted when CVE-2016-6835 or the next vulnerability affects your stack