What’s Vulnerable › Vulnerabilities
CVE-2016-6858
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Create Employee feature in Hybris Management Console (HMC) in SAP Hybris before 5.0.4.11, 5.1.0.x before 5.1.0.11, 5.1.1.x before 5.1.1.12, 5.2.0.x and 5.3.0.x before 5.3.0.10, 5.4.x before 5.4.0.9, 5.5.0.x before 5.5.0.9, 5.5.1.x before 5.5.1.10, 5.6.x before 5.6.0.8, and 5.7.x before 5.7.0.9 allows remote authenticated users to inject arbitrary web script or HTML via the Name field.
Affected products
- SAP SE SAP Commerce (ex. SAP Hybris Commerce): from 5.0.4 before 5.0.4.11; from 5.1.0 before 5.1.0.11; from 5.1.1 before 5.1.1.12; from 5.2.0 before 5.2.0.10; from 5.3.0 before 5.3.0.10; from 5.4.0 before 5.4.0.9 — fixed in 5.0.4.11, 5.1.0.11, 5.1.1.12, 5.2.0.10, 5.3.0.10, 5.4.0.9
How to fix
Upgrade to a fixed version: SAP SE SAP Commerce (ex. SAP Hybris Commerce) 5.0.4.11, 5.1.0.11, 5.1.1.12, 5.2.0.10. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/93966
- https://www.compass-security.com/fileadmin/Datein/Research/Advisories/CVE-2016-685X_SAP-Hybris_XSS.txt
- http://www.securityfocus.com/bid/93966
- https://www.compass-security.com/fileadmin/Datein/Research/Advisories/CVE-2016-685X_SAP-Hybris_XSS.txt
Get alerted when CVE-2016-6858 or the next vulnerability affects your stack