What’s Vulnerable › Vulnerabilities
CVE-2016-7048
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-284
Description
The interactive installer in PostgreSQL before 9.3.15, 9.4.x before 9.4.10, and 9.5.x before 9.5.5 might allow remote attackers to execute arbitrary code by leveraging use of HTTP to download software.
Affected products
- PostgreSQL: before 9.1.24; from 9.2 before 9.2.19; from 9.3 before 9.3.15; from 9.4.0 before 9.4.10; from 9.5.0 before 9.5.5 — fixed in 9.1.24, 9.2.19, 9.3.15, 9.4.10, 9.5.5
How to fix
Upgrade to a fixed version: PostgreSQL 9.1.24, 9.2.19, 9.3.15, 9.4.10. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1378043
- https://www.postgresql.org/support/security/
- https://bugzilla.redhat.com/show_bug.cgi?id=1378043
- https://www.postgresql.org/support/security/
Get alerted when CVE-2016-7048 or the next vulnerability affects your stack