What’s Vulnerable › Vulnerabilities
CVE-2016-7052
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 29.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-09-26 · updated 2026-06-17
- Weakness: CWE-476
Description
crypto/x509/x509_vfy.c in OpenSSL 1.0.2i allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) by triggering a CRL operation.
Affected products
- Node.js: from 4.0.0 through 4.1.2; from 4.2.0 before 4.6.0; from 6.0.0 before 6.7.0 — fixed in 4.6.0, 6.7.0
- Novell Suse Linux Enterprise Module For Web Scripting: 12.0
- OpenSSL: 1.0.2i
How to fix
Upgrade to a fixed version: Node.js 4.6.0, 6.7.0. Check the vendor advisory for mitigations.
References
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10759
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00013.html
- http://www-01.ibm.com/support/docview.wss?uid=swg21995039
- http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
- http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://www.securityfocus.com/bid/93171
- http://www.securitytracker.com/id/1036885
- https://bto.bluecoat.com/security-advisory/sa132
- https://git.openssl.org/?p=openssl.git%3Ba=commit%3Bh=6e629b5be45face20b4ca71c4fcbfed78b864a2e
Get alerted when CVE-2016-7052 or the next vulnerability affects your stack