What’s Vulnerable › Vulnerabilities
CVE-2016-7070
- Severity: high (CVSS 8.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-11 · updated 2026-06-17
- Weakness: CWE-266
Description
A privilege escalation flaw was found in the Ansible Tower. When Tower before 3.0.3 deploys a PostgreSQL database, it incorrectly configures the trust level of postgres user. An attacker could use this vulnerability to gain admin level access to the database.
Affected products
- Tower: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: Tower 3.0.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7070
- https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7070
- https://docs.ansible.com/ansible-tower/3.0.3/html/upgrade-migration-guide/release_notes.html
Get alerted when CVE-2016-7070 or the next vulnerability affects your stack