What’s Vulnerable › Vulnerabilities
CVE-2016-7071
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-10 · updated 2026-06-17
- Weakness: CWE-285
Description
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions controls to VM IDs passed by users. A remote, authenticated attacker could use this flaw to execute arbitrary VMs on systems managed by CloudForms if they know the ID of the VM.
Affected products
- CloudForms: 4.1
- Red Hat CloudForms: before 5.6.2.2; from 5.7.0.0 before 5.7.0.7 — fixed in 5.6.2.2, 5.7.0.7
How to fix
Upgrade to a fixed version: Red Hat CloudForms 5.6.2.2, 5.7.0.7. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2091.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7071
- http://rhn.redhat.com/errata/RHSA-2016-2091.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-7071
Get alerted when CVE-2016-7071 or the next vulnerability affects your stack