What’s Vulnerable › Vulnerabilities
CVE-2016-7103
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 29.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-03-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML via the closeText parameter of the dialog function.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 30, 35, 36
- Jqueryui Jquery Ui: from 1.10.0 through 1.11.4
- Juniper Junos OS: 21.2
- NetApp SnapCenter: all versions
- Oracle Corporation Application Express: before 19.1 — fixed in 19.1
- Oracle Corporation Oracle Business Intelligence Enterprise Edition: 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Hospitality Cruise Fleet Management: 9.0.11
- Oracle Corporation OSS Support Tools: before 2.12.42; 2.12.42 — fixed in 2.12.42
- Oracle Corporation Primavera Unifier: from 16.0 through 16.2; from 17.0 through 17.12.4; from 18.0 through 18.8.4
- Oracle Corporation Siebel UI Framework: through 21.2
- Oracle WebLogic Server: 10.3.6.0.0, 12.1.3.0.0, 12.2.1.3.0
- OpenStack: 7.0, 8, 9
How to fix
Upgrade to a fixed version: Oracle Corporation Application Express 19.1; Oracle Corporation OSS Support Tools 2.12.42. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2932.html
- http://rhn.redhat.com/errata/RHSA-2016-2933.html
- http://rhn.redhat.com/errata/RHSA-2017-0161.html
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- http://www.securityfocus.com/bid/104823
- https://github.com/jquery/api.jqueryui.com/issues/281
- https://github.com/jquery/jquery-ui/commit/9644e7bae9116edaf8d37c5b38cb32b892f10ff6
- https://jqueryui.com/changelog/1.12.0/
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/ba79cf1658741e9f146e4c59b50aee56656ea95d841d358d006c18b6%40%3Ccommits.roller.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc%40%3Cissues.drill.apache.org%3E
Get alerted when CVE-2016-7103 or the next vulnerability affects your stack