What’s Vulnerable › Vulnerabilities

CVE-2016-7117

Description

Use-after-free vulnerability in the __sys_recvmmsg function in net/socket.c in the Linux kernel before 4.5.2 allows remote attackers to execute arbitrary code via vectors involving a recvmmsg system call that is mishandled during error processing.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.102, 3.12.59, 3.14.67, 3.16.35. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-7117 or the next vulnerability affects your stack