What’s Vulnerable › Vulnerabilities
CVE-2016-7425
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-10-16 · updated 2026-06-17
- Weakness: CWE-119
Description
The arcmsr_iop_message_xfer function in drivers/scsi/arcmsr/arcmsr_hba.c in the Linux kernel through 4.8.2 does not restrict a certain length field, which allows local users to gain privileges or cause a denial of service (heap-based buffer overflow) via an ARCMSR_MESSAGE_WRITE_WQBUFFER control code.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 16.10
- Linux kernel: from 3.2 before 3.2.84; from 3.3 before 3.10.105; from 3.11 before 3.12.67; from 3.13 before 3.16.39; from 3.17 before 3.18.46; from 3.19 before 4.1.37 — fixed in 3.10.105, 3.12.67, 3.16.39, 3.18.46, 3.2.84, 4.1.37
How to fix
Upgrade to a fixed version: Linux kernel 3.10.105, 3.12.67, 3.16.39, 3.18.46. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=7bc2b55a5c030685b399bb65b6baa9ccc3d1f167
- http://marc.info/?l=linux-scsi&m=147394713328707&w=2
- http://marc.info/?l=linux-scsi&m=147394796228991&w=2
- http://www.openwall.com/lists/oss-security/2016/09/17/2
- http://www.securityfocus.com/bid/93037
- http://www.ubuntu.com/usn/USN-3144-1
- http://www.ubuntu.com/usn/USN-3144-2
- http://www.ubuntu.com/usn/USN-3145-1
- http://www.ubuntu.com/usn/USN-3145-2
- http://www.ubuntu.com/usn/USN-3146-1
- http://www.ubuntu.com/usn/USN-3146-2
- http://www.ubuntu.com/usn/USN-3147-1
Get alerted when CVE-2016-7425 or the next vulnerability affects your stack