What’s Vulnerable › Vulnerabilities
CVE-2016-7513
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-20 · updated 2026-06-17
- Weakness: CWE-189
Description
Off-by-one error in magick/cache.c in ImageMagick allows remote attackers to cause a denial of service (segmentation fault) via unspecified vectors.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93121
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=832455
- https://bugzilla.redhat.com/show_bug.cgi?id=1378733
- https://github.com/ImageMagick/ImageMagick/commit/a54fe0e8600eaf3dc6fe717d3c0398001507f723
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93121
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=832455
- https://bugzilla.redhat.com/show_bug.cgi?id=1378733
- https://github.com/ImageMagick/ImageMagick/commit/a54fe0e8600eaf3dc6fe717d3c0398001507f723
Get alerted when CVE-2016-7513 or the next vulnerability affects your stack