What’s Vulnerable › Vulnerabilities
CVE-2016-7515
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-19 · updated 2026-06-17
- Weakness: CWE-125
Description
The ReadRLEImage function in coders/rle.c in ImageMagick allows remote attackers to cause a denial of service (out-of-bounds read) via vectors related to the number of pixels.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93120
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1533445
- https://bugzilla.redhat.com/show_bug.cgi?id=1378741
- https://github.com/ImageMagick/ImageMagick/commit/2ad6d33493750a28a5a655d319a8e0b16c392de1
- https://github.com/ImageMagick/ImageMagick/issues/82
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93120
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1533445
- https://bugzilla.redhat.com/show_bug.cgi?id=1378741
- https://github.com/ImageMagick/ImageMagick/commit/2ad6d33493750a28a5a655d319a8e0b16c392de1
- https://github.com/ImageMagick/ImageMagick/issues/82
Get alerted when CVE-2016-7515 or the next vulnerability affects your stack