What’s Vulnerable › Vulnerabilities
CVE-2016-7520
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-20 · updated 2026-06-17
- Weakness: CWE-125
Description
Heap-based buffer overflow in coders/hdr.c in ImageMagick allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted HDR file.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1537213
- https://bugzilla.redhat.com/show_bug.cgi?id=1378747
- https://github.com/ImageMagick/ImageMagick/commit/14e606db148d6ebcaae20f1e1d6d71903ca4a556
- https://github.com/ImageMagick/ImageMagick/issues/90
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1537213
- https://bugzilla.redhat.com/show_bug.cgi?id=1378747
- https://github.com/ImageMagick/ImageMagick/commit/14e606db148d6ebcaae20f1e1d6d71903ca4a556
- https://github.com/ImageMagick/ImageMagick/issues/90
Get alerted when CVE-2016-7520 or the next vulnerability affects your stack