What’s Vulnerable › Vulnerabilities
CVE-2016-7524
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-06 · updated 2026-06-17
- Weakness: CWE-125
Description
coders/meta.c in ImageMagick allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted file.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1537422
- https://bugzilla.redhat.com/show_bug.cgi?id=1378762
- https://github.com/ImageMagick/ImageMagick/commit/97c9f438a9b3454d085895f4d1f66389fd22a0fb
- https://github.com/ImageMagick/ImageMagick/commit/f8c318d462270b03e77f082e2a3a32867cacd3c6
- https://github.com/ImageMagick/ImageMagick/issues/96
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1537422
- https://bugzilla.redhat.com/show_bug.cgi?id=1378762
- https://github.com/ImageMagick/ImageMagick/commit/97c9f438a9b3454d085895f4d1f66389fd22a0fb
- https://github.com/ImageMagick/ImageMagick/commit/f8c318d462270b03e77f082e2a3a32867cacd3c6
- https://github.com/ImageMagick/ImageMagick/issues/96
Get alerted when CVE-2016-7524 or the next vulnerability affects your stack