What’s Vulnerable › Vulnerabilities
CVE-2016-7526
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-20 · updated 2026-06-17
- Weakness: CWE-787
Description
coders/wpg.c in ImageMagick allows remote attackers to cause a denial of service (out-of-bounds write) via a crafted file.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/bugs/1539050
- https://bugzilla.redhat.com/show_bug.cgi?id=1378758
- https://github.com/ImageMagick/ImageMagick/commit/998c687fb83993c13fa711d75f59a95b38ceab77
- https://github.com/ImageMagick/ImageMagick/commit/b60d1ed0af37c50b91a40937825b4c61e8458095
- https://github.com/ImageMagick/ImageMagick/commit/b6ae2f9e0ab13343c0281732d479757a8e8979c7
- https://github.com/ImageMagick/ImageMagick/commit/d9b2209a69ee90d8df81fb124eb66f593eb9f599
- https://github.com/ImageMagick/ImageMagick/issues/102
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/bugs/1539050
Get alerted when CVE-2016-7526 or the next vulnerability affects your stack