What’s Vulnerable › Vulnerabilities
CVE-2016-7527
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-20 · updated 2026-06-17
- Weakness: CWE-125
Description
coders/wpg.c in ImageMagick allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted file.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93220
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1542115
- https://bugzilla.redhat.com/show_bug.cgi?id=1378759
- https://github.com/ImageMagick/ImageMagick/commit/a251039393f423c7858e63cab6aa98d17b8b7a41
- https://github.com/ImageMagick/ImageMagick/commit/b3dd69b23e9338806891c708a0cc8a82c0d1872a
- https://github.com/ImageMagick/ImageMagick/issues/122
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93220
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1542115
- https://bugzilla.redhat.com/show_bug.cgi?id=1378759
- https://github.com/ImageMagick/ImageMagick/commit/a251039393f423c7858e63cab6aa98d17b8b7a41
Get alerted when CVE-2016-7527 or the next vulnerability affects your stack