What’s Vulnerable › Vulnerabilities
CVE-2016-7534
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-20 · updated 2026-06-17
- Weakness: CWE-125
Description
The generic decoder in ImageMagick allows remote attackers to cause a denial of service (out-of-bounds access) via a crafted file.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1542785
- https://bugzilla.redhat.com/show_bug.cgi?id=1378767
- https://github.com/ImageMagick/ImageMagick/commit/430403b0029b37decf216d57f810899cab2317dd
- https://github.com/ImageMagick/ImageMagick/issues/126
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1542785
- https://bugzilla.redhat.com/show_bug.cgi?id=1378767
- https://github.com/ImageMagick/ImageMagick/commit/430403b0029b37decf216d57f810899cab2317dd
- https://github.com/ImageMagick/ImageMagick/issues/126
Get alerted when CVE-2016-7534 or the next vulnerability affects your stack