What’s Vulnerable › Vulnerabilities
CVE-2016-7535
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-20 · updated 2026-06-17
- Weakness: CWE-787
Description
coders/psd.c in ImageMagick allows remote attackers to cause a denial of service (out-of-bounds write) via a crafted PSD file.
Affected products
- ImageMagick: before 6.9.4-0 — fixed in 6.9.4-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1545180
- https://bugzilla.redhat.com/show_bug.cgi?id=1378768
- https://github.com/ImageMagick/ImageMagick/issues/128
- http://www.openwall.com/lists/oss-security/2016/09/22/2
- http://www.securityfocus.com/bid/93131
- https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1545180
- https://bugzilla.redhat.com/show_bug.cgi?id=1378768
- https://github.com/ImageMagick/ImageMagick/issues/128
Get alerted when CVE-2016-7535 or the next vulnerability affects your stack