What’s Vulnerable › Vulnerabilities
CVE-2016-7798
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-01-30 · updated 2026-06-17
- Weakness: CWE-326
Description
The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-*-gcm) when the IV is set before the key, which makes it easier for context-dependent attackers to bypass the encryption protection mechanism.
Affected products
- Debian Linux: 8.0, 9.0
- ruby-lang Openssl: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: ruby-lang Openssl 2.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/09/19/9
- http://www.openwall.com/lists/oss-security/2016/09/30/6
- http://www.openwall.com/lists/oss-security/2016/10/01/2
- http://www.securityfocus.com/bid/93031
- https://github.com/ruby/openssl/commit/8108e0a6db133f3375608303fdd2083eb5115062
- https://github.com/ruby/openssl/issues/49
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://www.debian.org/security/2017/dsa-3966
- http://www.openwall.com/lists/oss-security/2016/09/19/9
- http://www.openwall.com/lists/oss-security/2016/09/30/6
- http://www.openwall.com/lists/oss-security/2016/10/01/2
- http://www.securityfocus.com/bid/93031
Get alerted when CVE-2016-7798 or the next vulnerability affects your stack