What’s Vulnerable › Vulnerabilities

CVE-2016-7910

Description

Use-after-free vulnerability in the disk_seqf_stop function in block/genhd.c in the Linux kernel before 4.7.1 allows local users to gain privileges by leveraging the execution of a certain stop operation even if the corresponding start operation had failed.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.103, 3.12.63, 3.14.76, 3.16.39. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-7910 or the next vulnerability affects your stack