What’s Vulnerable › Vulnerabilities
CVE-2016-7913
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-11-16 · updated 2026-06-17
- Weakness: CWE-416
Description
The xc2028_set_config function in drivers/media/tuners/tuner-xc2028.c in the Linux kernel before 4.6 allows local users to gain privileges or cause a denial of service (use-after-free) via vectors involving omission of the firmware name from a certain data structure.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04
- Linux kernel: before 3.10.106; from 3.11 before 3.12.70; from 3.13 before 3.18.51; from 3.19 before 4.1.41; from 4.2 before 4.4.65; from 4.5 before 4.6 — fixed in 3.10.106, 3.12.70, 3.18.51, 4.1.41, 4.4.65, 4.6
How to fix
Upgrade to a fixed version: Linux kernel 3.10.106, 3.12.70, 3.18.51, 4.1.41. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8dfbcc4351a0b6d2f2d77f367552f48ffefafe18
- http://source.android.com/security/bulletin/2016-11-01.html
- http://www.securityfocus.com/bid/94201
- https://access.redhat.com/errata/RHSA-2018:0676
- https://access.redhat.com/errata/RHSA-2018:1062
- https://access.redhat.com/errata/RHSA-2019:1170
- https://access.redhat.com/errata/RHSA-2019:1190
- https://github.com/torvalds/linux/commit/8dfbcc4351a0b6d2f2d77f367552f48ffefafe18
- https://usn.ubuntu.com/3798-1/
- https://usn.ubuntu.com/3798-2/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8dfbcc4351a0b6d2f2d77f367552f48ffefafe18
- http://source.android.com/security/bulletin/2016-11-01.html
Get alerted when CVE-2016-7913 or the next vulnerability affects your stack