What’s Vulnerable › Vulnerabilities
CVE-2016-8212
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-03 · updated 2026-06-17
- Weakness: CWE-404
Description
An issue was discovered in EMC RSA BSAFE Crypto-J versions prior to 6.2.2. There is an Improper OCSP Validation Vulnerability. OCSP responses have two time values: thisUpdate and nextUpdate. These specify a validity period; however, both values are optional. Crypto-J treats the lack of a nextUpdate as indicating that the OCSP response is valid indefinitely instead of restricting its validity for a brief period surrounding the thisUpdate time. This vulnerability is similar to the issue described in CVE-2015-4748.
Affected products
- RSA BSAFE Crypto-J RSA BSAFE Crypto-J versions prior to 6.2.2: before 6.2.2 — fixed in 6.2.2
How to fix
Upgrade to a fixed version: RSA BSAFE Crypto-J RSA BSAFE Crypto-J versions prior to 6.2.2 6.2.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/archive/1/540066/30/0/threaded
- http://www.securityfocus.com/bid/95831
- http://www.securitytracker.com/id/1037732
- http://www.securityfocus.com/archive/1/540066/30/0/threaded
- http://www.securityfocus.com/bid/95831
- http://www.securitytracker.com/id/1037732
Get alerted when CVE-2016-8212 or the next vulnerability affects your stack