What’s Vulnerable › Vulnerabilities
CVE-2016-8365
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-03 · updated 2026-06-17
- Weakness: CWE-437
Description
OSIsoft PI System software (Applications using PI Asset Framework (AF) Client versions prior to PI AF Client 2016, Version 2.8.0; Applications using PI Software Development Kit (SDK) versions prior to PI SDK 2016, Version 1.4.6; PI Buffer Subsystem, versions prior to and including, Version 4.4; and PI Data Archive versions prior to PI Data Archive 2015, Version 3.4.395.64) operates between endpoints without a complete model of endpoint features potentially causing the product to perform actions based on this incomplete model, which could result in a denial of service. OSIsoft reports that in order to exploit the vulnerability an attacker would need to be locally connected to a server. A CVSS v3 base score of 7.1 has been calculated; the CVSS vector string is (AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H)
Affected products
- OSIsoft Pi Af Client: before 2.8.0 — fixed in 2.8.0
- OSIsoft Pi Buffer Subsystem: before 4.5.0 — fixed in 4.5.0
- OSIsoft PI Data Archive: before 3.4.400.1162 — fixed in 3.4.400.1162
- OSIsoft Pi Sdk: before 1.4.6 — fixed in 1.4.6
How to fix
Upgrade to a fixed version: OSIsoft Pi Af Client 2.8.0; OSIsoft Pi Buffer Subsystem 4.5.0; OSIsoft PI Data Archive 3.4.400.1162; OSIsoft Pi Sdk 1.4.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94165
- https://ics-cert.us-cert.gov/advisories/ICS-VU-313-03
- https://techsupport.osisoft.com/Troubleshooting/Alerts/AL00308
- http://www.securityfocus.com/bid/94165
- https://ics-cert.us-cert.gov/advisories/ICS-VU-313-03
- https://techsupport.osisoft.com/Troubleshooting/Alerts/AL00308
Get alerted when CVE-2016-8365 or the next vulnerability affects your stack