What’s Vulnerable › Vulnerabilities
CVE-2016-8399
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-12 · updated 2026-06-17
- Weakness: CWE-284
Description
An elevation of privilege vulnerability in the kernel networking subsystem could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and current compiler optimizations restrict access to the vulnerable code. Product: Android. Versions: Kernel-3.10, Kernel-3.18. Android ID: A-31349935.
Affected products
- Linux kernel: from 3.19 before 4.1.37; from 4.2 before 4.4.38; from 4.5 before 4.8.14 — fixed in 4.1.37, 4.4.38, 4.8.14
How to fix
Upgrade to a fixed version: Linux kernel 4.1.37, 4.4.38, 4.8.14. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-0817.html
- http://www.securityfocus.com/bid/94708
- https://access.redhat.com/errata/RHSA-2017:0869
- https://access.redhat.com/errata/RHSA-2017:2930
- https://access.redhat.com/errata/RHSA-2017:2931
- https://source.android.com/security/bulletin/2016-12-01.html
- https://support.f5.com/csp/article/K23030550?utm_source=f5support&%3Butm_medium=RSS
- http://rhn.redhat.com/errata/RHSA-2017-0817.html
- http://www.securityfocus.com/bid/94708
- https://access.redhat.com/errata/RHSA-2017:0869
- https://access.redhat.com/errata/RHSA-2017:2930
- https://access.redhat.com/errata/RHSA-2017:2931
Get alerted when CVE-2016-8399 or the next vulnerability affects your stack