What’s Vulnerable › Vulnerabilities
CVE-2016-8609
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-01 · updated 2026-06-17
- Weakness: CWE-384
Description
It was found that the keycloak before 2.3.0 did not implement authentication flow correctly. An attacker could use this flaw to construct a phishing URL, from which he could hijack the user's session. This could lead to information disclosure, or permit further possible attacks.
Affected products
- Keycloak: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Keycloak 2.3.0. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2945.html
- http://www.securityfocus.com/bid/95070
- http://www.securitytracker.com/id/1037460
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8609
- http://rhn.redhat.com/errata/RHSA-2016-2945.html
- http://www.securityfocus.com/bid/95070
- http://www.securitytracker.com/id/1037460
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8609
Get alerted when CVE-2016-8609 or the next vulnerability affects your stack