What’s Vulnerable › Vulnerabilities
CVE-2016-8612
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Apache HTTP Server mod_cluster before version httpd 2.4.23 is vulnerable to an Improper Input Validation in the protocol parsing logic in the load balancer resulting in a Segmentation Fault in the serving httpd process.
Affected products
- Apache HTTP Server: before 2.4.23 — fixed in 2.4.23
- NetApp Storage Automation Store: all versions
- Red Hat Enterprise Linux: 6.0, 7.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.23. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2957.html
- http://www.securityfocus.com/bid/94939
- https://access.redhat.com/errata/RHSA-2017:0193
- https://access.redhat.com/errata/RHSA-2017:0194
- https://bugzilla.redhat.com/show_bug.cgi?id=1387605
- https://security.netapp.com/advisory/ntap-20180601-0005/
- http://rhn.redhat.com/errata/RHSA-2016-2957.html
- http://www.securityfocus.com/bid/94939
- https://access.redhat.com/errata/RHSA-2017:0193
- https://access.redhat.com/errata/RHSA-2017:0194
- https://bugzilla.redhat.com/show_bug.cgi?id=1387605
- https://security.netapp.com/advisory/ntap-20180601-0005/
Get alerted when CVE-2016-8612 or the next vulnerability affects your stack