What’s Vulnerable › Vulnerabilities
CVE-2016-8614
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-31 · updated 2026-06-17
- Weakness: CWE-358
Description
A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.
Affected products
- Red Hat Ansible: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.2.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94108
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8614
- https://github.com/ansible/ansible-modules-core/issues/5237
- https://github.com/ansible/ansible-modules-core/pull/5353
- https://github.com/ansible/ansible-modules-core/pull/5357
- http://www.securityfocus.com/bid/94108
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8614
- https://github.com/ansible/ansible-modules-core/issues/5237
- https://github.com/ansible/ansible-modules-core/pull/5353
- https://github.com/ansible/ansible-modules-core/pull/5357
Get alerted when CVE-2016-8614 or the next vulnerability affects your stack