What’s Vulnerable › Vulnerabilities
CVE-2016-8628
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-31 · updated 2026-06-17
- Weakness: CWE-77
Description
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
Affected products
- Red Hat Ansible: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.2.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94109
- https://access.redhat.com/errata/RHSA-2016:2778
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8628
- http://www.securityfocus.com/bid/94109
- https://access.redhat.com/errata/RHSA-2016:2778
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8628
Get alerted when CVE-2016-8628 or the next vulnerability affects your stack