What’s Vulnerable › Vulnerabilities
CVE-2016-8654
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-01 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap-buffer overflow vulnerability was found in QMFB code in JPC codec caused by buffer being allocated with too small size. jasper versions before 2.0.0 are affected.
Affected products
- Debian Linux: 8.0
- jasper: before 2.0.0 — fixed in 2.0.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: jasper 2.0.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94583
- https://access.redhat.com/errata/RHSA-2017:1208
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8654
- https://github.com/mdadams/jasper/commit/4a59cfaf9ab3d48fca4a15c0d2674bf7138e3d1a
- https://github.com/mdadams/jasper/issues/93
- https://github.com/mdadams/jasper/issues/94
- https://www.debian.org/security/2017/dsa-3785
- http://www.securityfocus.com/bid/94583
- https://access.redhat.com/errata/RHSA-2017:1208
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8654
- https://github.com/mdadams/jasper/commit/4a59cfaf9ab3d48fca4a15c0d2674bf7138e3d1a
- https://github.com/mdadams/jasper/issues/93
Get alerted when CVE-2016-8654 or the next vulnerability affects your stack