What’s Vulnerable › Vulnerabilities
CVE-2016-8655
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-12-08 · updated 2026-06-17
- Weakness: CWE-362
Description
Race condition in net/packet/af_packet.c in the Linux kernel through 4.8.12 allows local users to gain privileges or cause a denial of service (use-after-free) by leveraging the CAP_NET_RAW capability to change a socket version, related to the packet_set_ring and packet_setsockopt functions.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 16.10
- Linux kernel: from 3.2 before 3.2.85; from 3.3 before 3.10.106; from 3.11 before 3.12.69; from 3.13 before 3.16.40; from 3.17 before 3.18.46; from 3.19 before 4.1.37 — fixed in 3.10.106, 3.12.69, 3.16.40, 3.18.46, 3.2.85, 4.1.37
How to fix
Upgrade to a fixed version: Linux kernel 3.10.106, 3.12.69, 3.16.40, 3.18.46. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=84ac7260236a49c79eede91617700174c2c19b0c
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00055.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00056.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00067.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00070.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00073.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00087.html
- http://packetstormsecurity.com/files/140063/Linux-Kernel-4.4.0-AF_PACKET-Race-Condition-Privilege-Escalation.html
Get alerted when CVE-2016-8655 or the next vulnerability affects your stack