What’s Vulnerable › Vulnerabilities
CVE-2016-8751
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Apache Ranger before 0.6.3 is vulnerable to a Stored Cross-Site Scripting in when entering custom policy conditions. Admin users can store some arbitrary javascript code to be executed when normal users login and access policies.
Affected products
- Apache Software Foundation Apache Ranger: before 0.6.3 — fixed in 0.6.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ranger 0.6.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/99067
- https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger
- http://www.securityfocus.com/bid/99067
- https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger
Get alerted when CVE-2016-8751 or the next vulnerability affects your stack