What’s Vulnerable › Vulnerabilities
CVE-2016-9063
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-10-08
- Weakness: CWE-190
Description
An integer overflow during the parsing of XML using the Expat library. This vulnerability affects Firefox < 50.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Mozilla Firefox: before 50 — fixed in 50
- Python: from 2.7.0 before 2.7.15; from 3.3.0 before 3.3.7; from 3.4.0 before 3.4.7; from 3.5.0 before 3.5.4; from 3.6.0 before 3.6.2 — fixed in 2.7.15, 3.3.7, 3.4.7, 3.5.4, 3.6.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 50; Python 2.7.15, 3.3.7, 3.4.7, 3.5.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94337
- http://www.securitytracker.com/id/1037298
- http://www.securitytracker.com/id/1039427
- https://bugzilla.mozilla.org/show_bug.cgi?id=1274777
- https://www.debian.org/security/2017/dsa-3898
- https://www.mozilla.org/security/advisories/mfsa2016-89/
- http://www.securityfocus.com/bid/94337
- http://www.securitytracker.com/id/1037298
- http://www.securitytracker.com/id/1039427
- https://bugzilla.mozilla.org/show_bug.cgi?id=1274777
- https://www.debian.org/security/2017/dsa-3898
- https://www.mozilla.org/security/advisories/mfsa2016-89/
Get alerted when CVE-2016-9063 or the next vulnerability affects your stack