What’s Vulnerable › Vulnerabilities
CVE-2016-9064
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-295
Description
Add-on updates failed to verify that the add-on ID inside the signed package matched the ID of the add-on being updated. An attacker who could perform a man-in-the-middle attack on the user's connection to the update server and defeat the certificate pinning protection could provide a malicious signed add-on instead of a valid update. This vulnerability affects Firefox ESR < 45.5 and Firefox < 50.
Affected products
- Mozilla Firefox: before 45.5.0; before 50.0 — fixed in 45.5.0, 50.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 45.5.0, 50.0. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2780.html
- http://www.securityfocus.com/bid/94336
- http://www.securitytracker.com/id/1037298
- https://bugzilla.mozilla.org/show_bug.cgi?id=1303418
- https://security.gentoo.org/glsa/201701-15
- https://www.mozilla.org/security/advisories/mfsa2016-89/
- https://www.mozilla.org/security/advisories/mfsa2016-90/
- http://rhn.redhat.com/errata/RHSA-2016-2780.html
- http://www.securityfocus.com/bid/94336
- http://www.securitytracker.com/id/1037298
- https://bugzilla.mozilla.org/show_bug.cgi?id=1303418
- https://security.gentoo.org/glsa/201701-15
Get alerted when CVE-2016-9064 or the next vulnerability affects your stack