What’s Vulnerable › Vulnerabilities
CVE-2016-9069
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-18 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free in nsINode::ReplaceOrInsertBefore during DOM operations resulting in potentially exploitable crashes. This vulnerability affects Firefox < 50.
Affected products
- Mozilla Firefox: before 50.0 — fixed in 50.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 50.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94337
- http://www.securitytracker.com/id/1037298
- https://bugzilla.mozilla.org/show_bug.cgi?id=1308922
- https://www.mozilla.org/security/advisories/mfsa2016-89/
- http://www.securityfocus.com/bid/94337
- http://www.securitytracker.com/id/1037298
- https://bugzilla.mozilla.org/show_bug.cgi?id=1308922
- https://www.mozilla.org/security/advisories/mfsa2016-89/
Get alerted when CVE-2016-9069 or the next vulnerability affects your stack