What’s Vulnerable › Vulnerabilities

CVE-2016-9083

Description

drivers/vfio/pci/vfio_pci.c in the Linux kernel through 4.8.11 allows local users to bypass integer overflow checks, and cause a denial of service (memory corruption) or have unspecified other impact, by leveraging access to a vfio PCI device file for a VFIO_DEVICE_SET_IRQS ioctl call, aka a "state machine confusion bug."

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.107, 3.12.70, 3.16.39, 3.18.51. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-9083 or the next vulnerability affects your stack