What’s Vulnerable › Vulnerabilities
CVE-2016-9401
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-23 · updated 2026-06-17
- Weakness: CWE-416
Description
popd in bash might allow local users to bypass the restricted shell and cause a use-after-free via a crafted address.
Affected products
- Debian Linux: 8.0
- GNU Bash: before 4.4; 4.4-patch1, 4.4-patch2, 4.4-patch3, 4.4-patch4, 4.4-patch5 — fixed in 4.4
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Eus: 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: GNU Bash 4.4. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-0725.html
- http://www.openwall.com/lists/oss-security/2016/11/17/5
- http://www.openwall.com/lists/oss-security/2016/11/17/9
- http://www.securityfocus.com/bid/94398
- https://access.redhat.com/errata/RHSA-2017:1931
- https://lists.debian.org/debian-lts-announce/2019/03/msg00028.html
- https://security.gentoo.org/glsa/201701-02
- http://rhn.redhat.com/errata/RHSA-2017-0725.html
- http://www.openwall.com/lists/oss-security/2016/11/17/5
- http://www.openwall.com/lists/oss-security/2016/11/17/9
- http://www.securityfocus.com/bid/94398
- https://access.redhat.com/errata/RHSA-2017:1931
Get alerted when CVE-2016-9401 or the next vulnerability affects your stack