What’s Vulnerable › Vulnerabilities
CVE-2016-9576
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-28 · updated 2026-06-17
- Weakness: CWE-416
Description
The blk_rq_map_user_iov function in block/blk-map.c in the Linux kernel before 4.8.14 does not properly restrict the type of iterator, which allows local users to read or write to arbitrary kernel memory locations or cause a denial of service (use-after-free) by leveraging access to a /dev/sg device.
Affected products
- Linux kernel: from 4.0 before 4.4.38; from 4.5 before 4.8.14 — fixed in 4.4.38, 4.8.14
How to fix
Upgrade to a fixed version: Linux kernel 4.4.38, 4.8.14. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=a0ac402cfcdc904f9772e1762b3fda112dcc56a0
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00062.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00072.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00075.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00081.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00088.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00091.html
- http://rhn.redhat.com/errata/RHSA-2017-0817.html
- http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.14
Get alerted when CVE-2016-9576 or the next vulnerability affects your stack