What’s Vulnerable › Vulnerabilities
CVE-2016-9586
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-23 · updated 2026-06-17
- Weakness: CWE-122
Description
curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.
Affected products
- curl: before 7.52.0 — fixed in 7.52.0
How to fix
Upgrade to a fixed version: curl 7.52.0. Check the vendor advisory for mitigations.
References
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
- http://www.securityfocus.com/bid/95019
- http://www.securitytracker.com/id/1037515
- https://access.redhat.com/errata/RHSA-2018:3558
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9586
- https://curl.haxx.se/docs/adv_20161221A.html
- https://github.com/curl/curl/commit/curl-7_51_0-162-g3ab3c16
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2018/11/msg00005.html
- https://security.gentoo.org/glsa/201701-47
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
Get alerted when CVE-2016-9586 or the next vulnerability affects your stack