What’s Vulnerable › Vulnerabilities
CVE-2016-9590
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-26 · updated 2026-06-17
- Weakness: CWE-200
Description
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
Affected products
- OpenStack Puppet-Swift: from 8.0.0 before 8.2.1; from 9.0.0 before 9.4.4 — fixed in 8.2.1, 9.4.4
- OpenStack: 8, 9, 10
How to fix
Upgrade to a fixed version: OpenStack Puppet-Swift 8.2.1, 9.4.4. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-0200.html
- http://rhn.redhat.com/errata/RHSA-2017-0359.html
- http://rhn.redhat.com/errata/RHSA-2017-0361.html
- http://www.securityfocus.com/bid/95448
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9590
- http://rhn.redhat.com/errata/RHSA-2017-0200.html
- http://rhn.redhat.com/errata/RHSA-2017-0359.html
- http://rhn.redhat.com/errata/RHSA-2017-0361.html
- http://www.securityfocus.com/bid/95448
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9590
Get alerted when CVE-2016-9590 or the next vulnerability affects your stack